Se stai aggiornando WordPress alla versione 5.4 facilmente troverai un brutto errore nelle pagine,

tipo questo:

category_link is deprecated since version 2.5.0! Use term_link instead. in /home/myPage/public_html/wp-includes/functions.php on line 5088

 

Ebbene sì, anche le release di una delle community più imponenti come WordPress sbagliano.

D’altronde un guru una volta mi disse che non esistono programmi perfetti, ma solo idee.

 

Per risolvere il problema, come suggerisce  l’utente Alpha, in questo topic, basta:

aprire il file taxonomy.php dentro la cartella wp-includes e modificare il seguente codice:

$termlink = apply_filters_deprecated( 'tag_link', array( $termlink, $term->term_id ), '2.5.0', 'term_link' );

con questo

$termlink = apply_filters( 'tag_link', $termlink, $term->term_id );

in queste 2 righe: 4256 e 4268.

 

E’ tutto!

Iscriviti alla newsletter qui sotto se vuoi rimanere aggiornato sulle novità di WordPress.

 

 

 

0 commenti

Lascia un Commento

Vuoi partecipare alla discussione?
Fornisci il tuo contributo!

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.